SonicWall Security Center
Share: Linkedin Share Facebook Like
Back to SonicALERT


HPE Intelligent Management Center Integer Underflow Vulnerability (Aug 3, 2017)



Description


The HPE Intelligent Management Center (IMC) Basic Software Platform is a network management, software tool with unified resource and device management providing a lower total cost of ownership. The platform is designed for small to medium sized businesses with small network environments that need a single display screen to show their network infrastructures. The Wireless Services Manager (WSM) Module provides uniformity over a wireless network for even geographically dispersed network. The WSM module uses several methods of authentication, one of which is the "Wireless Protocol".

A stack buffer overflow vulnerability exists in WSM module of HPE Intelligent Management Center. The vulnerabilty occurs when a special message was sent when WSM is parsing it without validating the fields correctly. A remote, unauthenticated attacker could exploit this vulnerability to execute arbitrary code remotely on the target server in the context of SYSTEM or root. This vulnerability has been assigned by the Common Vulnerabilities and Exposures with ID CVE-2017-5804.

SonicWall threat research team has researched this vulnerability and released the following IPS signature:

  • IPS:12915 HPE Intelligent Management Center Buffer Overflow 5



Back to top

Back to SonicALERT

Follow: Follow us on Facebook Follow us on Twitter Join the Conversation
#SonicWall
© 2017 SonicWall | Privacy Policy | Conditions for use | Feedback | Live Demo | SonicALERT | Document Library | Report Issues
Version: 13.3 | S2MSW06